易语言快捷搜索信息与快捷录入信息的代码

 更新时间:2018-11-22 04:00:46   作者:佚名   我要评论(0)

快捷录入信息与关键词匹配功能代码


.版本 2
.程序集 窗口程序集1
.程序集变量 快捷信息, 文本型
.程序集变量 分割信息, 文本型, , "0"
.子程序 _输入编辑框

快捷录入信息与关键词匹配功能代码

.版本 2
.程序集 窗口程序集1
.程序集变量 快捷信息, 文本型
.程序集变量 分割信息, 文本型, , "0"
.子程序 _输入编辑框_内容被改变
.局部变量 M, 整数型
.如果真 (输入编辑框.内容 = “”)
  内容列表框.可视 = 假
  返回 ()
.如果真结束
内容列表框.清空 ()
.计次循环首 (取数组成员数 (分割信息), M)
  .如果 (寻找文本 (分割信息 [M], 输入编辑框.内容, , 假) ≠ -1)
    内容列表框.插入项目 (0, 分割信息 [M], )
    内容列表框.可视 = 真
  .否则
  .如果结束
.计次循环尾 ()
.如果 (内容列表框.取项目数 () = 0)
  内容列表框.可视 = 假
.否则
  .如果真 (内容列表框.取项目数 () ≤ 10)
    内容列表框.高度 = 14 × 内容列表框.取项目数 ()
  .如果真结束
  .如果真 (内容列表框.取项目数 () > 10)
    内容列表框.高度 = 140
  .如果真结束
.如果结束
.子程序 __启动窗口_创建完毕
快捷信息 = 到文本 (读入文件 (取运行目录 () + “\信息源.txt”))
分割信息 = 分割文本 (快捷信息, “*”, )
.子程序 _录入按钮_被单击
写到文件 (取运行目录 () + “\信息源.txt”, 到字节集 (输入编辑框.内容 + “*” + 快捷信息))
__启动窗口_创建完毕 ()
.子程序 _内容列表框_列表项被选择
输入编辑框.内容 = 内容列表框.取项目文本 (内容列表框.现行选中项)
内容列表框.清空 ()
内容列表框.可视 = 假
.子程序 _输入编辑框_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型
.如果真 (键代码 = 40)
  内容列表框.现行选中项 = 内容列表框.现行选中项 + 1
.如果真结束
.如果真 (键代码 = 38)
  内容列表框.现行选中项 = 内容列表框.现行选中项 - 1
.如果真结束
.如果真 (键代码 = 13)
  _内容列表框_列表项被选择 ()
.如果真结束

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

  • 易语言取出两个编辑框中相同内容的代码
  • 易语言信息框调用子程序返回结果的代码
  • 易语言文本排列的代码实例
  • 易语言使用到循环尾命令实现过滤变量的代码
  • 易语言猜随机数小游戏的代码
  • 易语言使用倒找文本命令的代码实例
  • 易语言使用变量循环首命令显示0到50之间所有偶数的代码
  • 易语言将文本按照指定字符分割的代码
  • 易语言表格不显示滚动条的代码
  • 易语言制作窗口信息探测工具的代码
  • 易语言利用取字符实现Excel列号与字母互转功能的代码
  • 易语言使用标签实现进度条功能的代码
  • 易语言将两个EXE文件捆绑成一个文件的打包工具
  • 易语言HOOKAPI钩子操作代码实例
  • 易语言自定义数据类型的使用代码

相关文章

  • 易语言快捷搜索信息与快捷录入信息的代码

    易语言快捷搜索信息与快捷录入信息的代码

    快捷录入信息与关键词匹配功能代码 .版本 2 .程序集 窗口程序集1 .程序集变量 快捷信息, 文本型 .程序集变量 分割信息, 文本型, , "0" .子程序 _输入编辑框
    2018-11-22
  • 易语言取出两个编辑框中相同内容的代码

    易语言取出两个编辑框中相同内容的代码

    对比两个编辑框内容的代码 .版本 2 .程序集 窗口程序集1 .子程序 _对比按钮_被单击 .局部变量 循环计次1, 整数型 .局部变量 文本1, 文本型, , "0" .局部变量
    2018-11-22
  • Android Camera2 实现预览功能

    Android Camera2 实现预览功能

    1. 概述 最近在做一些关于人脸识别的项目,需要用到 Android 相机的预览功能。网上查阅相关资料后,发现 Android 5.0 及以后的版本中,原有的 Camera API 已经
    2018-11-22
  • 易语言自定义数据类型的使用代码

    易语言自定义数据类型的使用代码

    自定义数据类型表 .版本 2 .数据类型 消息类型 .成员 键盘消息, 文本型 自定义数据类型使用代码 .版本 2 .程序集 窗口程序集1 .子程序 _按钮1_被单击
    2018-11-22
  • android实现菜单三级树效果

    android实现菜单三级树效果

    本文实例为大家分享了android实现菜单三级树展示的具体代码,供大家参考,具体内容如下 以下是部分代码,完整代码请在最下面点击下载: 【MainActivity】
    2018-11-22
  • Android自定义简单的顶部标题栏

    Android自定义简单的顶部标题栏

    本文实例为大家分享了Android实现简单顶部标题栏的具体代码,供大家参考,具体内容如下 实现功能: 1)自定义View标题栏布局; 2)灵活的可以自己传入类型
    2018-11-22
  • Android ExpandableListView双层嵌套实现三级树形菜单

    Android ExpandableListView双层嵌套实现三级树形菜单

    在Android开发中,列表可以说是最常见的了,一般都是使用ListView,当涉及到二维数组时,更多的使用到ExpandableListView,然而当数据结构比较复杂时,就需要
    2018-11-22
  • 如何去除富文本中的html标签及vue、react、微信小程序中的过滤器

    如何去除富文本中的html标签及vue、react、微信小程序中的过滤器

    在获取富文本后,又只要显示部分内容,需要去除富文本标签,然后再截取其中一部分内容;然后就是过滤器,在微信小程序中使用还是挺多次的,在vue及react中也遇
    2018-11-22
  • ExpandableListView实现二级列表购物车

    ExpandableListView实现二级列表购物车

    android中常常要用到ListView,有时也要用到ExpandableListView,如在手机设置中,对于分类有很好的效果,会用ListView的人一定会用ExpandableListView,因为
    2018-11-22
  • java并发之原子操作类和非阻塞算法

    java并发之原子操作类和非阻塞算法

    背景 近年来,在并发算法领域的大多数研究都侧重于非阻塞算法,这种算法用底层的原子机器指令(例如比较并发交换指令)代替锁来确保数据在并发访问中的一致
    2018-11-22

最新评论