易语言监控smtp和反编译获取程序内邮件密码发送信息达到反钓鱼的目的

 更新时间:2018-11-25 06:00:13   作者:佚名   我要评论(0)

监控smtp和反编译获取程序内邮件密码、发送信息达到反钓鱼的目的
反邮箱钓鱼程序源码


.版本 2
.支持库 EThread
.支持库 eAPI
.支持库 xplib
.支持库 edropt

监控smtp和反编译获取程序内邮件密码、发送信息达到反钓鱼的目的

反邮箱钓鱼程序源码

.版本 2
.支持库 EThread
.支持库 eAPI
.支持库 xplib
.支持库 edroptarget
.支持库 pop3
.支持库 iext
.程序集 窗口程序集1
.程序集变量 服务器, 文本型
.程序集变量 帐号, 文本型
.程序集变量 密码, 文本型
.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型
.局部变量 钓鱼软件, 字节集
.局部变量 邮箱位置, 整数型
.局部变量 空白文本, 整数型
.局部变量 跳过, 整数型
.局部变量 邮箱, 字节集, , "0"
.局部变量 扩展名, 文本型
.局部变量 服务器验证, 文本型, , "0"
扩展名 = 取文本右边 (接收到的文件路径, 3)
扩展名 = 到小写 (扩展名)
.如果 (扩展名 = “exe”)
  钓鱼软件 = 读入文件 (接收到的文件路径)
  邮箱位置 = 寻找字节集 (钓鱼软件, 到字节集 (“smtp.”), )
  跳过 = 倒找字节集 (钓鱼软件, { 0 }, 邮箱位置)
  跳过 = 倒找字节集 (钓鱼软件, { 0 }, 跳过 - 1)
  跳过 = 倒找字节集 (钓鱼软件, { 0 }, 跳过 - 1)
  空白文本 = 寻找字节集 (钓鱼软件, { 0 }, 邮箱位置)
  钓鱼软件 = 取字节集中间 (钓鱼软件, 跳过, 空白文本 - 跳过)
  邮箱 = 分割字节集 (钓鱼软件, { 0 }, )
  删除成员 (邮箱, 1, 1)
  重定义数组 (邮箱, 真, 取数组成员数 (邮箱))
  .如果真 (取数组成员数 (邮箱) = 3)
    报表.加入文本 (“服务器:” + 到文本 (邮箱 [3]) + “ 帐号:” + 到文本 (邮箱 [2]) + “ 密码:” + 到文本 (邮箱 [1]) + #换行符 + #换行符)
    服务器验证 = 分割文本 (到文本 (邮箱 [3]), “.”, )
    .判断开始 (服务器验证 [2] = “QQ”)
      服务器 = “pop.qq.com”
    .默认
    .判断结束
    .判断开始 (服务器验证 [2] = “163”)
      服务器 = “pop.163.com”
    .默认
    .判断结束
    帐号 = 到文本 (邮箱 [2])
    密码 = 到文本 (邮箱 [1])
    启动线程 (&获取信息, , )
  .如果真结束
  钓鱼软件 = { }
  清除数组 (邮箱)
.否则
  .如果 (扩展名 = “lnk”)
    接收到的文件路径 = 取快捷方式目标 (接收到的文件路径, , , , , , , )
    钓鱼软件 = 读入文件 (接收到的文件路径)
    邮箱位置 = 寻找字节集 (钓鱼软件, 到字节集 (“smtp.”), )
    跳过 = 倒找字节集 (钓鱼软件, { 0 }, 邮箱位置)
    跳过 = 倒找字节集 (钓鱼软件, { 0 }, 跳过 - 1)
    跳过 = 倒找字节集 (钓鱼软件, { 0 }, 跳过 - 1)
    空白文本 = 寻找字节集 (钓鱼软件, { 0 }, 邮箱位置)
    钓鱼软件 = 取字节集中间 (钓鱼软件, 跳过, 空白文本 - 跳过)
    邮箱 = 分割字节集 (钓鱼软件, { 0 }, )
    删除成员 (邮箱, 1, 1)
    重定义数组 (邮箱, 真, 取数组成员数 (邮箱))
    .如果真 (取数组成员数 (邮箱) = 3)
      报表.加入文本 (“服务器:” + 到文本 (邮箱 [3]) + “ 帐号:” + 到文本 (邮箱 [2]) + “ 密码:” + 到文本 (邮箱 [1]) + #换行符 + #换行符)
      服务器验证 = 分割文本 (到文本 (邮箱 [3]), “.”, )
      .判断开始 (服务器验证 [2] = “QQ”)
        服务器 = “pop.qq.com”
      .默认
      .判断结束
      .判断开始 (服务器验证 [2] = “163”)
        服务器 = “pop.163.com”
      .默认
      .判断结束
      帐号 = 到文本 (邮箱 [2])
      密码 = 到文本 (邮箱 [1])
      启动线程 (&获取信息, , )
    .如果真结束
    钓鱼软件 = { }
    清除数组 (邮箱)
  .否则
    报表.加入文本 (“非可执行文件无法获取” + #换行符)
  .如果结束
.如果结束
.子程序 __启动窗口_创建完毕
XP风格 (1)
拖放对象1.注册拖放控件 (取窗口句柄 ())
.子程序 获取信息
.局部变量 邮件个数, 整数型
.局部变量 邮件大小, 整数型
.局部变量 n1, 整数型
.局部变量 邮件信息, 邮件信息
超级列表框1.全部删除 ()
.如果 (连接收信服务器 (服务器, 110, 帐号, 密码, 30000, 3) = 真)
  获取邮件信息 (邮件个数, 邮件大小)
  .计次循环首 (邮件个数, n1)
    邮件信息 = 接收邮件 (n1)
    超级列表框1.插入表项 (n1 - 1, 到文本 (n1), , , , )
    超级列表框1.置标题 (n1 - 1, 1, 邮件信息.取主题 ())
    超级列表框1.置标题 (n1 - 1, 2, 邮件信息.取文本内容 ())
    超级列表框1.置标题 (n1 - 1, 3, 到文本 (邮件信息.取日期 ()))
  .计次循环尾 ()
.否则
.如果结束
.子程序 _超级列表框1_鼠标右键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
弹出菜单 (菜单, , )
.子程序 _查看详情_被选择
报表.加入文本 (“标题:” + 超级列表框1.取标题 (超级列表框1.现行选中项, 1) + #换行符 + 超级列表框1.取标题 (超级列表框1.现行选中项, 2) + #换行符 + 超级列表框1.取标题 (超级列表框1.现行选中项, 3) + #换行符)
.子程序 _删除邮件_被选择
.判断开始 (删除邮件 (超级列表框1.现行选中项 + 1) = 真)
  超级列表框1.删除表项 (超级列表框1.现行选中项)
.默认
.判断结束

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

  • 易语言调用墨迹天气实现自动定位获取天气情况的代码
  • 易语言通过枚举密码进行破解rar压缩包文件的代码
  • 易语言调用百度图片识别实现的图片转表格的代码
  • 易语言超级列表框点击表头进行排序的代码
  • 易语言验证十八位身份证号码是否正确的代码
  • 易语言实现反OD调试反复附加的代码
  • 易语言通过解析免费下载QQ付费音乐的代码
  • 易语言免费免登陆不限次数下载千图网图片的代码
  • 易语言修改快捷方式进行微信多开的代码
  • 易语言调用JS制作统计文本字数的代码
  • 易语言抽取幸运号控制子程序暂停与继续运行的代码
  • 易语言制作推箱子小游戏的代码
  • 易语言获取计算机硬盘信息的代码
  • 易语言获取任意按键对应的键代码
  • 易语言获取随机数并且不重复的代码

相关文章

最新评论