易语言调用墨迹天气实现自动定位获取天气情况的代码

 更新时间:2018-11-25 06:00:14   作者:佚名   我要评论(0)

常量数据表


.版本 2
.常量 实况头, "<文本长度: 9>"
.常量 实况尾, "<文本长度: 2>"
.常量 更新时间头, "<文本长度: 28>"
.常量 更新时间尾, "<文本长度: 9

常量数据表

.版本 2
.常量 实况头, "<文本长度: 9>"
.常量 实况尾, "<文本长度: 2>"
.常量 更新时间头, "<文本长度: 28>"
.常量 更新时间尾, "<文本长度: 9>"
.常量 温度头, "<文本长度: 28>"
.常量 温度尾, "<文本长度: 5>"
.常量 空气质量头, "<文本长度: 43>"
.常量 空气质量尾, "<文本长度: 2>"
.常量 湿度头, "<文本长度: 10>"
.常量 湿度尾, "<文本长度: 7>"
.常量 今日提示头, "<文本长度: 43>"
.常量 今日提示尾, "<文本长度: 23>"
.常量 风向头, "<文本长度: 26>"
.常量 风向尾, "<文本长度: 7>"
.常量 天气头, "<文本长度: 26>"
.常量 卖帮提醒头, "<文本长度: 34>"
.常量 卖帮提醒尾, "<文本长度: 4>"
.常量 卖帮提醒头1, "<文本长度: 8>"
.常量 卖帮提醒尾1, "<文本长度: 33>"
.常量 天气尾, "<文本长度: 4>"

实时天气自动定位源码

此功能需要加载精易模块5.6

.版本 2
.支持库 iconv
.支持库 internet
.支持库 iext
.程序集 窗口程序集1
.程序集变量 天气, 文本型
.程序集变量 城市实况, 文本型
.程序集变量 更新时间, 文本型
.程序集变量 温度, 文本型
.程序集变量 空气质量, 文本型
.程序集变量 湿度, 文本型
.程序集变量 今日提示, 文本型
.程序集变量 风向, 文本型
.程序集变量 卖帮提醒, 文本型
.程序集变量 卖帮提醒1, 文本型
.程序集变量 今日天气, 文本型
.子程序 取文本_中间文本, 文本型, 公开
.参数 参_被寻找文本, 文本型
.参数 参_左边文本, 文本型
.参数 参_右边文本, 文本型
.局部变量 起点, 整数型
.局部变量 终点, 整数型
.局部变量 文本, 文本型
起点 = 寻找文本 (参_被寻找文本, 参_左边文本, , 假)
.判断开始 (起点 = -1)
  返回 (“”)
.默认
  起点 = 起点 + 取文本长度 (参_左边文本)
.判断结束
终点 = 寻找文本 (参_被寻找文本, 参_右边文本, 起点, 假)
.判断开始 (终点 = -1)
  返回 (“”)
.默认
  文本 = 取文本中间 (参_被寻找文本, 起点, 终点 - 起点)
  返回 (文本)
.判断结束
.子程序 URL编码, 文本型
.参数 URL, 文本型
.局部变量 Len, 整数型
.局部变量 循环容器, 整数型
.局部变量 Asc, 整数型
.局部变量 目标, 文本型
.局部变量 临时, 文本型
Len = 取文本长度 (URL)
.变量循环首 (1, Len, 1, 循环容器)
  Asc = 取代码 (URL, 循环容器)
  Asc = 选择 (Asc < 0, 256 + Asc, Asc)
  .如果 (Asc < 42 或 Asc = 43 或 Asc > 57 且 Asc < 64 或 Asc > 90 且 Asc < 95 或 Asc = 96 或 Asc > 122)
    临时 = 取十六进制文本 (Asc)
    目标 = 目标 + 选择 (取文本长度 (临时) < 2, “%0” + 临时, “%” + 临时)
  .否则
    目标 = 目标 + 字符 (Asc)
  .如果结束
.变量循环尾 ()
返回 (目标)
.子程序 _天气时钟_周期事件
天气 = 到文本 (编码转换 (HTTP读文件 (“http://tianqi.moji.com/”), #编码_UTF_8, #编码_GB18030, ))
城市实况 = 取文本_中间文本 (天气, #实况头, #实况尾)
透明标签1_城市.标题 = “城市:” + 城市实况
更新时间 = 取文本_中间文本 (天气, #更新时间头, #更新时间尾)
透明标签1_更新时间.标题 = “更新时间:” + 更新时间
温度 = 取文本_中间文本 (天气, #温度头, #温度尾)
透明标签1_温度.标题 = “温度:” + 温度 + “℃”
空气质量 = 取文本_中间文本 (天气, #空气质量头, #空气质量尾)
透明标签1_空气质量.标题 = “空气质量:” + 空气质量
湿度 = 取文本_中间文本 (天气, #湿度头, #湿度尾)
透明标签1_湿度.标题 = “湿度:” + 湿度
今日提示 = 取文本_中间文本 (天气, #今日提示头, #今日提示尾)
透明标签1_今日提示.标题 = “今日提示:” + 今日提示
风向 = 取文本_中间文本 (天气, #风向头, #风向尾)
透明标签1_风向.标题 = “风向:” + 风向 + “级”
今日天气 = 取文本_中间文本 (天气, #天气头, #天气尾)
透明标签1_今日天气.标题 = “今日天气:” + 今日天气
卖帮提醒 = 取文本_中间文本 (天气, #卖帮提醒头, #卖帮提醒尾)
卖帮提醒1 = 取文本_中间文本 (天气, #卖帮提醒头1, #卖帮提醒尾1)
透明标签1_提醒.标题 = 卖帮提醒 + “卖帮小助手” + 卖帮提醒1
_启动窗口.标题 = 城市实况

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

  • 易语言通过枚举密码进行破解rar压缩包文件的代码
  • 易语言调用百度图片识别实现的图片转表格的代码
  • 易语言超级列表框点击表头进行排序的代码
  • 易语言验证十八位身份证号码是否正确的代码
  • 易语言实现反OD调试反复附加的代码
  • 易语言通过解析免费下载QQ付费音乐的代码
  • 易语言免费免登陆不限次数下载千图网图片的代码
  • 易语言修改快捷方式进行微信多开的代码
  • 易语言调用JS制作统计文本字数的代码
  • 易语言抽取幸运号控制子程序暂停与继续运行的代码
  • 易语言制作推箱子小游戏的代码
  • 易语言获取计算机硬盘信息的代码
  • 易语言获取任意按键对应的键代码
  • 易语言获取随机数并且不重复的代码
  • 易语言监控smtp和反编译获取程序内邮件密码发送信息达到反钓鱼的目的

相关文章

最新评论