易语言通过百度错误页面获取北京时间的代码

 更新时间:2018-11-25 06:00:20   作者:佚名   我要评论(0)

利用百度取北京时间源码


.版本 2
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
.局部变量 XML对象, 对象
.局部变量 时间文本, 文本型
.局部变量 网络时

利用百度取北京时间源码

.版本 2
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
.局部变量 XML对象, 对象
.局部变量 时间文本, 文本型
.局部变量 网络时间, 日期时间型
.如果真 (XML对象.创建 (“WinHttp.WinHttpRequest.5.1”, ))
  XML对象.方法 (“SetTimeouts”, 5000, 5000, 10000, 5000)
  XML对象.写属性 (“Option”, 6, 0)
  XML对象.方法 (“open”, “HEAD”, “http://www.baidu.com/jb51.net”, 假)
  XML对象.方法 (“send”, )
  时间文本 = XML对象.读属性 (“GetResponseHeader”, “Date”).取文本 ()
.如果真结束
网络时间 = 时间格式化 (时间文本)
时间编辑框.内容 = 到文本 (时间文本) + #换行符 + 到文本 (网络时间)
.子程序 时间格式化, 日期时间型
.参数 时间文本, 文本型
.局部变量 临时数组, 文本型, , "0"
.局部变量 临时变量, 文本型
.局部变量 时间变量, 日期时间型
.局部变量 临时时间, 日期时间型
.局部变量 日, 文本型
.局部变量 月, 文本型
.局部变量 年, 文本型
.局部变量 时, 文本型
.局部变量 分, 文本型
.局部变量 秒, 文本型
临时数组 = 分割文本 (时间文本, “, ”, )
临时变量 = 临时数组 [2]
临时变量 = 子文本替换 (临时变量, “ GMT”, , , , 真)
清除数组 (临时数组)
临时数组 = 分割文本 (临时变量, “ ”, )
日 = 临时数组 [1]
.判断开始 (临时数组 [2] = “Jan”)
  月 = “01”
.判断 (临时数组 [2] = “Feb”)
  月 = “02”
.判断 (临时数组 [2] = “Mar”)
  月 = “03”
.判断 (临时数组 [2] = “Apr”)
  月 = “04”
.判断 (临时数组 [2] = “Mar”)
  月 = “05”
.判断 (临时数组 [2] = “Jun”)
  月 = “06”
.判断 (临时数组 [2] = “Jul”)
  月 = “07”
.判断 (临时数组 [2] = “Aug”)
  月 = “08”
.判断 (临时数组 [2] = “Sep”)
  月 = “09”
.判断 (临时数组 [2] = “Oct”)
  月 = “10”
.判断 (临时数组 [2] = “Nov”)
  月 = “11”
.判断 (临时数组 [2] = “Dec”)
  月 = “12”
.默认
.判断结束
年 = 临时数组 [3]
临时变量 = 临时数组 [4]
清除数组 (临时数组)
临时数组 = 分割文本 (临时变量, “:”, )
时 = 到文本 (到整数 (临时数组 [1]))
分 = 临时数组 [2]
秒 = 临时数组 [3]
时间变量 = 到时间 (年 + “/” + 月 + “/” + 日 + “/” + 时 + “/” + 分 + “/” + 秒)
时间变量 = 增减时间 (时间变量, #小时, 8)
返回 (时间变量)

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

  • 易语言仿按键精灵录制键盘鼠标操作的代码
  • 易语言实现YY批量自动加好友的代码
  • 易语言通过get的方式多线程刷微视播放量的代码
  • 易语言用夜神模拟器实现抖音自动点赞和评论的代码
  • 易语言通过路径来判断是不是在压缩包内运行的代码
  • 易语言解析获得无水印下载地址的代码
  • 易语言NTAPI进程操纵的代码
  • 易语言通过注册表将易文件关联修复的源码
  • 易语言注册机生成永久或限时注册码的写法
  • 易语言制作一款唯美的cookie分析工具的代码
  • 易语言多线程多任务下载器的代码
  • 易语言调用墨迹天气实现自动定位获取天气情况的代码
  • 易语言通过枚举密码进行破解rar压缩包文件的代码
  • 易语言调用百度图片识别实现的图片转表格的代码
  • 易语言实现截图或右键二维码识别的代码

相关文章

最新评论