易语言用夜神模拟器实现抖音自动点赞和评论的代码

 更新时间:2018-11-25 06:00:18   作者:佚名   我要评论(0)

用夜神模拟器实现抖音自动点赞和评论的代码
实现此功能需要加载精易模块5.6和大漠中文类模块
分辨率设置800x600,窗口大小设置固定。


.版本 2
.支持库 iext

用夜神模拟器实现抖音自动点赞和评论的代码

实现此功能需要加载精易模块5.6和大漠中文类模块

分辨率设置800x600,窗口大小设置固定。

.版本 2
.支持库 iext
.支持库 iext2
.程序集 窗口程序集_启动窗口
.程序集变量 集_大漠, 大漠中文类
.程序集变量 集_句柄, 整数型
.程序集变量 集_评论内容, 文本型
.程序集变量 集_分割文本, 文本型, , "0"
.子程序 __启动窗口_创建完毕
集_大漠.初始_创建_破解 ()
置随机数种子 ()
.子程序 功能_取句柄, 整数型
.局部变量 局_句柄, 整数型
局_句柄 = 窗口_取句柄 (, , “Qt5QWindowIcon”, “夜神模拟器”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
局_句柄 = 窗口_取句柄 (局_句柄, , “Qt5QWindowIcon”, “ScreenBoardClassWindow”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
返回 (局_句柄)
.子程序 功能_取句柄2, 整数型, , 本子程序采用【精易编程助手】生成,成功返回窗口句柄,失败返回0
.局部变量 局_句柄, 整数型
局_句柄 = 窗口_取句柄 (, , “Qt5QWindowIcon”, “夜神模拟器”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
局_句柄 = 窗口_取句柄 (局_句柄, , “Qt5QWindowIcon”, “ScreenBoardClassWindow”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
局_句柄 = 窗口_取句柄 (局_句柄, , “Qt5QWindowIcon”, “QWidgetClassWindow”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
返回 (局_句柄)
.子程序 双击爱心收藏
集_大漠.鼠标_移动 (297, 209)
集_大漠.鼠标_双击左键 ()
.子程序 弹出评论框
集_大漠.鼠标_移动Ex (568, 549, 2, 2)
集_大漠.鼠标_单击左键 ()
.子程序 开始写评论
集_大漠.鼠标_移动Ex (100, 773, 2, 2)
集_大漠.鼠标_单击左键 ()
程序_延时 (500)
文本_投递 (集_句柄, 集_评论内容)
.子程序 点击发送
集_大漠.鼠标_移动Ex (589, 774, 2, 2)
集_大漠.鼠标_单击左键 ()
.子程序 关闭评论框
集_大漠.鼠标_移动Ex (279, 195, 3, 3)
集_大漠.鼠标_双击左键 ()
.子程序 _超级按钮7_被单击
集_句柄 = 功能_取句柄 ()
.判断开始 (集_句柄 = 0)
  透明标签1.标题 = “绑定失败,你是否打开了夜神模拟器?”
.默认
  集_大漠.后台_绑定窗口 (集_句柄, “gdi”, “windows”, “windows”, 0)
  超级按钮1.禁止 = 假
  透明标签1.标题 = “绑定成功( ̄▽ ̄)/”
.判断结束
.子程序 _超级按钮1_被单击
.局部变量 n, 整数型
.局部变量 局_停止标识符, 整数型
局_停止标识符 = 1
.判断开始 (超级按钮1.标题 = “开始执行脚本”)
  .判断开始 (编辑框2.内容 = “”)
    信息框 (“评论内容不要为空哟。”, 64, , )
  .判断 (编辑框4.内容 = “”)
    信息框 (“执行次数不要为空哟。”, 64, , )
  .判断 (编辑框1.内容 = “”)
    信息框 (“间隔时间不要为空哟。”, 64, , )
  .默认
    集_分割文本 = 分割文本 (编辑框2.内容, #换行符, )
    超级按钮1.标题 = “停止执行脚本”
    局_停止标识符 = 1
    信息框 (“脚本开始运行了哟。”, 64, , )
    程序_延时 (1000)
    .计次循环首 (到数值 (编辑框4.内容), n)
      .判断开始 (n = 到数值 (编辑框4.内容))
        超级按钮1.标题 = “开始执行脚本”
      .默认
      .判断结束
      .判断开始 (局_停止标识符 = 0)
        跳出循环 ()
      .默认
      .判断结束
      开始运行脚本 ()
      程序_延时 (到数值 (编辑框1.内容))
    .计次循环尾 ()
  .判断结束
.判断 (超级按钮1.标题 = “停止执行脚本”)
  局_停止标识符 = 0
  超级按钮1.标题 = “开始执行脚本”
.默认
.判断结束
.子程序 开始运行脚本
.局部变量 集_运行次数, 整数型
.局部变量 局_运行次数, 整数型
.局部变量 局_评论标识符, 整数型
.局部变量 i, 整数型
i = i + 1
.判断开始 (i > 取数组成员数 (集_分割文本))
  i = 1
.默认
.判断结束
.判断开始 (选择框3.选中 = 真)
  局_评论标识符 = 取随机数 (1, 取数组成员数 (集_分割文本))
  集_评论内容 = 集_分割文本 [局_评论标识符]
.默认
  集_评论内容 = 集_分割文本 [i]
.判断结束
.判断开始 (选择框1.选中 = 真)
  双击爱心收藏 ()
  程序_延时 (2000)
.默认
.判断结束
.判断开始 (选择框2.选中 = 真)
  弹出评论框 ()
  程序_延时 (2000)
  开始写评论 ()
  程序_延时 (2000)
  点击发送 ()
  程序_延时 (800)
  关闭评论框 ()
  程序_延时 (2000)
.默认
.判断结束
集_大漠.鼠标_移动 (297, 209)
集_大漠.鼠标_滚轮下滚 ()
程序_延时 (4000)
处理事件 ()

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

  • 易语言仿按键精灵录制键盘鼠标操作的代码
  • 易语言实现YY批量自动加好友的代码
  • 易语言通过get的方式多线程刷微视播放量的代码
  • 易语言通过路径来判断是不是在压缩包内运行的代码
  • 易语言解析获得无水印下载地址的代码
  • 易语言NTAPI进程操纵的代码
  • 易语言通过注册表将易文件关联修复的源码
  • 易语言注册机生成永久或限时注册码的写法
  • 易语言制作一款唯美的cookie分析工具的代码
  • 易语言通过百度错误页面获取北京时间的代码
  • 易语言多线程多任务下载器的代码
  • 易语言调用墨迹天气实现自动定位获取天气情况的代码
  • 易语言通过枚举密码进行破解rar压缩包文件的代码
  • 易语言调用百度图片识别实现的图片转表格的代码
  • 易语言实现截图或右键二维码识别的代码

相关文章

最新评论