易语言通过路径来判断是不是在压缩包内运行的代码

 更新时间:2018-11-25 06:00:24   作者:佚名   我要评论(0)

判断是不是在压缩包内运行的代码


.版本 2
.程序集 窗口程序集_启动窗口
.子程序 __启动窗口_创建完毕
.局部变量 运行目录, 文本型
.局部变量 解压名称, 文本

判断是不是在压缩包内运行的代码

.版本 2
.程序集 窗口程序集_启动窗口
.子程序 __启动窗口_创建完毕
.局部变量 运行目录, 文本型
.局部变量 解压名称, 文本型
.局部变量 开始位置, 整数型
.局部变量 结束位置, 整数型
运行目录 = 取运行目录 ()
开始位置 = 倒找文本 (运行目录, “$”, , 假)
结束位置 = 倒找文本 (运行目录, “\”, 开始位置, 假) + 1
解压名称 = 到小写 (取文本中间 (运行目录, 结束位置, 开始位置 - 结束位置))
.如果 (解压名称 ≠ “”)
  .如果真 (解压名称 = “hz”)
    解压名称 = “好压”
  .如果真结束
  .如果真 (解压名称 = “rar”)
    解压名称 = “WinRar”
  .如果真结束
  .如果真 (解压名称 = “360”)
    解压名称 = “360压缩”
  .如果真结束
  判断标签.标题 = “在” + 解压名称 + “内”
.否则
  判断标签.标题 = “不在压缩包内”
.如果结束

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:

  • 易语言仿按键精灵录制键盘鼠标操作的代码
  • 易语言实现YY批量自动加好友的代码
  • 易语言通过get的方式多线程刷微视播放量的代码
  • 易语言用夜神模拟器实现抖音自动点赞和评论的代码
  • 易语言解析获得无水印下载地址的代码
  • 易语言NTAPI进程操纵的代码
  • 易语言通过注册表将易文件关联修复的源码
  • 易语言注册机生成永久或限时注册码的写法
  • 易语言制作一款唯美的cookie分析工具的代码
  • 易语言通过百度错误页面获取北京时间的代码
  • 易语言多线程多任务下载器的代码
  • 易语言调用墨迹天气实现自动定位获取天气情况的代码
  • 易语言通过枚举密码进行破解rar压缩包文件的代码
  • 易语言调用百度图片识别实现的图片转表格的代码
  • 易语言实现截图或右键二维码识别的代码

相关文章

最新评论