易语言统计重复数教学

 更新时间:2019-01-08 12:00:09   作者:佚名   我要评论(0)

比如1 2 3 3 5 4 6 5 4 8 7 3 2这么多数字想取重复数据,并统计重复次数,可以用易语言编程来实现。

1、易语言新建程序

2、新建一个Windows窗口程序

3、如

比如1 2 3 3 5 4 6 5 4 8 7 3 2这么多数字想取重复数据,并统计重复次数,可以用易语言编程来实现。

1、易语言新建程序

2、新建一个Windows窗口程序

3、如下图所示,亲建2个编辑框,1个选择框,1个按钮,并做好相应排版。

4、双击取重复按钮,并编写如下代码:

.版本 2

.支持库 EDataStructure

.局部变量 zcf, 文本型, , "0"

.局部变量 i, 整数型

.局部变量 ii, 整数型

.局部变量 个数, 整数型

.局部变量 节点, 节点

zcf = 分割文本 (编辑框1.内容, #换行符, )

.计次循环首 (取数组成员数 (zcf), i)

 个数 = 0

 .计次循环首 (取数组成员数 (zcf), ii)

  .如果真 (zcf [i] = zcf [ii])

   个数 = 个数 + 1

  .如果真结束

 .计次循环尾 ()

 .如果真 (节点.加入属性 (到文本 (zcf [i]), 0))

  .如果真 (个数 ≠ 1)

   .如果 (选择框2.选中 = 真)

    编辑框2.加入文本 (zcf [i] + “----重复” + 到文本 (个数) + “次” + #换行符)

   .否则

    编辑框2.加入文本 (zcf [i] + #换行符)

   .如果结束

  .如果真结束

 .如果真结束

.计次循环尾 ()

5、编译试运行,在编辑框1里面加入一组含重复项数据,选择看重复项选择框,点击取重复按钮,重复数据与重复次数就出现在右边的编辑框了,是不是很简单,如果有帮到您,请点击左下角的投票哦,希望大家能从本经验中学到知识收获快乐。

相关文章

最新评论